Crazy fan speed on rog laptop

After several months using an ASUS ROG GL503GE notebook, its fans started to behave in a strange way.

With no reason, the GPU fan speed jumps to 7000rpm. Sometimes, it stays there for hours, sometimes it keeps waiving. Usually, after some hours, it stabilized in normal speed (at last until the next reboot).

I checked the internet forums, and found several reports from people having the same problem. I tried to update and to drowngrade de BIOS, I tried to use fan control softwares, I tried to trick the ROG Gaming Center, I tried MSI Afterburner, I tried Intel XTU utilities, I update all the drivers and Windows 10 itself. Nothing solved the problem, and even worse, I could not figure out why it was happening, and what was triggering it.

Note that the CPU temperature usually was < 40C, and the GPU was not even being used! So, there was no reason for the fan to became a turbine, bothering everyone near to me.

Finally, some “good soul” posted in a ROG forum’s thread in the ROG saying that he solved the problem just opening the notebook, disconnecting the battery and fan cables, and connecting everything back.

I decided to try it, before I get crazy with the strong noise coming from the “turbine”, every day.

Before disconnecting the cables, I carefully checked if there was some bad contact or even a disconnection. No! Everything was perfectly connected. Even so, I disconnected the battery and the fan cables, and reconnected a few minutes later. I also blew some air to clean the fans, but they were really clean (those fans are supposed to be dust free, and seems that they really are).

For my surprise, this procedure seems to have solved the problem. Four days had passed and the problem didn’t show up anymore! What a relief!

For those who are having the same problem, you can search in youtube for GL503 tear-down videos. Opening the notebook is really an easy task. Just release a bunch of bolts to have access to the battery and fan cables.

Just a note: ASUS support was of no help at all! Since my notebook is still under warranty, they asked me to send it to RMA. But there was some problems:

1) I would need to ship it to USA
2) I use this notebook for work, so no way to stay weeks (months?) waiting for it come back
3) I read several posts from people with the same problem, which have sent their notebooks to RMA one, two and even three times, and they didn’t solve the problem.

I used to assembly computers in the 90’s, and ASUS motherboards was the best ones in that time. I though their notebooks would offer the same quality, but they don’t. Beside this problem with the fans, they also have “coil whine” noise. I would not buy it again.